Loading ...

The system Theme settings have change.d You must restart your application to apply those settings. | CLEARIFY

Posted in: QQube    General Usage

System theme settings have changed-restart application to apply

Subscribe to RSS
  • Ok have an odd issue not sure it is directly related to QQube.

    System: QuickBooks 17.0 running on a Windows Server 2012 R2 off site. Users use remote desktop to access.

    System has worked fine in the past started having issues within the past month.

    The current process is to have user QQube logged into the server. Have QQube running, Quickbooks open without being logged into a company and power bi gateway running. Then to log out of the remote desktop using 

    %windir%\System32\tscon.exe 12 /dest:console which disconnects but leaves the session running. 

    This has worked without issue until recently. Now when I log back in i receive multiple pop ups saying "The system Theme settings have change.d You must restart your application to apply those settings." and because this error QQube is unable to run the sync process. 

  • This is a QuickBooks/Windows issue:

    The original document used to fix this is no longer available as 4/10/2020

    We found the following information here: https://help.developer.intuit.com/s/question/0D50f00004p44wvCAA/remove-warning-after-windows-resolution-changes

    **********************************************

    Here is something to try:

    https://social.technet.microsoft.com/Forums/ie/en-US/b49de36e-d36f-4f7c-a63e-b70c49c86efd/compatibility-administrator-and-the-old-setting-quotdisable-visual-themesquot?forum=w8itproappcompat 

    These are the instructions I came up with for QB2020 Enterprise. You might have to adjust the directory being used.

    Run Regedit

    Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers 

    See if you have a QBW32.exe entry there.

    If not, open a file browser and go to C:\Program Files (x86)\Intuit\QuickBooks Enterprise Solutions 20.0 Scroll down to the QBW32.exe program, right click and select properties Go to the Compatibility Tab and check the Compatibility mode box and Select Apply. 

    Flip back to Regedit and do an F5 (to refresh the screen).

    You should now see an entry for C:\Program Files (x86)\Intuit\QuickBooks Enterprise Solutions 20.0\QBW32.EXE 

    Edit that data entry and add DISABLETHEMES behind the ~ WIN8RTM.

    So, it should look like this when you are finished:

    Value Data: ~ WIN8RTM DISABLETHEMES 

    Now Flip back over to the QBW32.exe properties and uncheck the compatibility box.

    Go back to Regedit and do an F5 again and it should just have "~ DISABLETHEMES" now as an entry.

     

  • Yeah I found the same thing.

    While i believe the issue is related to QB and Windows, this answer does not make sense since no company file is being accessed. This error is given immediately after executing the console log off and logging back in. 

    Do you have suggestions on running your software in a multi user environment in an office site location? How would you handle having a dedicated user logged in?

  • We get this internally when resizing some of our Virtual Machine test beds.  As to how to fix it, well, another matter.  Have you tried changing the resolution within that user?

    It appears that you have followed our instructions - because you have the dedicated user, and QB open to no company file.

    When I get something like this - where it has been running for a while, and now doesn't - is to back track and figure out what has changed.  It is only a month, so chances are you might point to an update, an upgrade, etc.   Have you checked the event log?  Have you called Intuit support? (a company file is not open, but QB is open - so you have grounds on which to discuss with them).

  • So interesting thing is we are actually running on a dedicated machine due to an issue that arose after upgrading to QB 17 that caused extreme lag on the virtual machine that neither intuit or our provider could diagnose, even tried a clean virtual machine and encountered the same issue. 

    Changing the resolution of local machine to the same resolution as the remote server does not appear to resolve the issue. 

    Is there no way to run QQUBE as a service so a user does not have to be logged in?

    Yeah, I contacted our provider to see if they can diagnose the issue. 

  • Answered

    Unfortunately no.  Intuit SDK does not allow any application to talk to QB in elevated mode.  Thus the true and tried methods shown in our instructions.

Page 1 of 1 (6 items)